www.jdownloads.com

0 Members and 2 Guests are viewing this topic.

Joomla 4 compatibility
« on: 31.05.2022 02:17:36 »
Hello,
You probably answer this before, but I wasn't able to find the answer about plans to make this great extension Joomla 4 compatible, it will be greatly appreciated if possible.
Many thanks,
Kind regards,
Jose.
*
Re: Joomla 4 compatibility
« Reply #1 on: 31.05.2022 10:26:19 »
Hi
We are working on the jD4 version.  Decided to to make jD4 use the new J4 structures so it is a signiicant internal change.  Most of these affect the admin side. Alpha testing of the Admin is in progres.
 
#When will it be done - as soon as feasible.  We will be recruiting beta stage testers in due course.
Colin
Colin M
Re: Joomla 4 compatibility
« Reply #2 on: 07.07.2022 00:05:47 »
Just wondering how far along the J!4 version has gotten. I have a site that needs immediate upgrading to J!4 and it uses jDownloads. If there's a somewhat stable version I'm happy to test it, but I have to make a decision right now as to which way I'll go with the downloads system. This site is not a major download thing - it's just staff documents (nothing open to public view) available after logging in. It also needs the ability for my client to upload/renew the downloads.
*
Re: Joomla 4 compatibility
« Reply #3 on: 07.07.2022 15:55:43 »
Hi
As I said earlier we are working on jD4.  Predicting when we will be doe is a challenge
The backend is looking good as are the modules.
But it is not yet in a useable form.   The changes made in J4 are very significant.  We are going for a full transition not a patched one!
I really think it will be autumn this year, say October for first release.

May I ask what is the essential reason for switching to J4?
Colin
Colin M
Re: Joomla 4 compatibility
« Reply #4 on: 07.07.2022 23:24:18 »
I have found that J!4 is significantly faster. That alone is worth the upgrade IMHO. Also, J!3 and the extensions it uses often have significant issues with PHP8 which I want to get all my sites onto. PHP7.4 is near EoL so it's logical, not to mention smart, to upgrade to PHP8. I've had a huge bunch of issues with various extensions under PHP8.
*
Re: Joomla 4 compatibility
« Reply #5 on: 08.07.2022 10:35:11 »
Hi
Yes J4 is faster and PHP8 is better.  Also the J4 architecture is 'cleaner' but has some, shall I say, unexpected twists!!

The first few release of J4 were a little unstable/unfinished so we had to wait until things settled down before we could begin the jD4 work.

Colin
Colin M
*
Re: Joomla 4 compatibility
« Reply #6 on: 10.07.2022 10:13:34 »
Hi
To give you some idea of the changes in J4.2 from J3.10 please see
https://docs.joomla.org/Potential_backward_compatibility_issues_in_Joomla_4

Some of these mean much re-coding

Colin
Colin M