0 Members and 1 Guest are viewing this topic.


- Joomla! 3.10.3 Stable
- jDownloads Version 3.2.69
- PHP 5.5.38
- mysql 5.1.49-0.dotdeb.0-log


First, sorry in advance if the explaination i will give look confusing, english is not my mother tongue. I'll do my best to explain all details i can. Also the images are in french, just so you are aware.

A few month ago, our client (aasri.org)'s host provider had a web hosting issue that made all website go down. When the issue was resolved, our client started having issue with uploading files on the backend. Basically we get an HTTP error when trying to upload anything when going on "submit files". (see link below)


From there, i proposed to the person managing this (he is in super user group) to upload the files from the frontend, on the website, because it worked there.

Now, on the 17.11.2021, he got a new issue where he couldn't upload anymore on the frontend. he got this message when trying to upload:
"The upload failed with the following error: Invalid file size, aborted sending." (see image below)


I checked myself if i could upload anything of any size but i get the same error (i'm also Super user on this site, we have all permissions).
I tried to change the max file size both on the php (for backend) and on the user group parameters, but it didn't change anything. I tried to contact the host provider, but they said the problem doesn't come from their end. Also tried to update Jdownloads but i can't because it need a newer version of PHP but the host can only provide up to PHP 5.5. When trying to create a new upload from the backend in "jDownloads>downloads" it succesfully create the download page but it doesn't actually give the file we want to download, saying it's "only a reading document".

If you need more informations, i'll do my best to provide them.

Thank you for any future help.

This is challenging!My first reaction is to change your hosting service!!!
Have not seen such behavior with jD3.2.69 or any othere version!Is Downloading from the front end OK?

In Config -  uploads tab you could try changing Uploader Runtime (for backemd uploads) - but not hpopeful.

You could also try locating the downloadable files in another site
Colin M
hello there,

First thank you for the quick reply.

Yes we though about maybe changing the hosting service.

The downloading work fine on the frontend, actually everything work fine except the upload.

Ok i tried every Uploader Runtime on the backend, surprisingly the HTML4 managed to work and succesfully uploaded the files.  ;D
I must say this is a big relief for me (the client was starting to get impatient y'know.) I'll give the good news to the client that he can upload again from the backend (like initially before the incident).

edit: hum... the files should appear under jdownloads:files correct? because if so the files doesn't appear...

A big thank you for the ideas!
« Last Edit: 01.12.2021 09:34:25 by aliax »
Do not fully undertsand the remark" hum... the files should appear under jdownloads:files correct? because if so the files doesn't appear..."
If you mean in the backend they appear in Downloads - they do not appear in Files
The Files option is another way of uploading Files and making them in to Downloads.  With this method the files are only listed there until they have been made into Downloads

see https://www.jdownloads.net/documentation-for-v3-9/options-configuration-v3-9/files-example for more info NB if you select language at top right  on documentation page it will auto translate into the selected language

Colin M
Ah sorry, what i mean is that when i upload new files in the backend using "submit files" (like i said it seems to work using HTML4's Uploader Runtime) afterward it doesn't appear in "File"... or in "Download" actually. Or maybe i'm missing something. If it's the case, i'm sorry.

When creating new downloads from the front end the 'Files' method is not used. 
In the backend they appear in the 'Telechargements' not the 'Ficheurs'
In your picture you have searched for 'test'   Is that correct?
Colin M
Hi Aliax,
I can only echo Colin's recommendation!
Please urge your customer to change hosters. The current one really doesn't seem to be up to date. With such old PHP versions they will get problems sooner or later. Also, not all server settings seem to be correct here. When choosing a hoster you should not take the cheapest one. More important is the good and fast support as well as the up-to-date equipment. I have a very good hoster in DE and pay only 10€ monthly (for all 10 domains). So the cost factor can no longer be a reason these days!

To your problem. Also the reason for this seems for me to be your hoster. Please remember that these problems did not occur in the past. This started only after your hoster got technical problems (as they themselves report). I think it is a problem with wrong permission server settings.

It makes little sense for us to look for solutions within jDownloads now. Because normally this works for all other users without any problems.

By the way, you could test this functionality it self on another hoster.
Either on our demo installation here:
   Use this data for login:
   Username: demo Password: demo
or on the Joomla.org here:
   There you can install jDownloads, configure it and test the upload.

The upload failed with the following error: Invalid file size, aborted sending."
Please check here the server settings. See pic.
« Last Edit: 01.12.2021 16:11:19 by Arno »
Best Regards / Gruß
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Thank you for the replies. Yes i think the best solution will be to move the website on another hosters like you suggested.

Again thank you for the help.