www.jdownloads.com

0 Members and 1 Guest are viewing this topic.

*
When I use the plugin content , I have the Following error message:
0 Call to a member function get() on null
when I try to display a page using content plugin. Displaying downloads with menus run normally
I use the last version of Jdwonloads 3.9.7.3 
Joomla version is 3.9.25
PHP version 7.4
I have tried 7.3 et 8.0 php version and the error still occur
Has someone any ideas?
Thank for your help
« Last Edit: 19.03.2021 22:25:34 by Arno »
*
Re: Error with plgin content
« Reply #1 on: 18.03.2021 22:37:23 »
Hi,
we cannot see a problem with the plugin. See our examples on the test and demonstration website:
https://www.jdownloads.org/plugin-examples.html
Here is the same version installed.

Please send a link to your website via PM and if possible more information on how you use the plugin. Did you have this problem only after the update to 3.9.7.3?
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!
*
Re: Error with plgin content
« Reply #2 on: 19.03.2021 07:39:19 »
Hi
I already checked your demo website in order to find help and obviously, the plugin content run fine in your website.
I am a new user of Jdownloads that is intended to replace the remository component  that will not be compliant with joomla 4. I installed first Jdownloads 3.9.7.2 some days ago and just upgraded to 3.9.7.3. The issue is the same whatever the version.

I use the plugin by inclunding {jd_file file==48} in a joomla content where 48 is the ID of existing download. But the issue is the same with another usage of th plugin (latest instead of file). the download run fine with the menu documents

Jdownload and the plugin are installed on my test wbesite Plugin https://val.mslc.fr and  access to randonnee menu or https://val.mslc.fr/randonnee.html as direct access.
I send you an account by PM.

Many thanks
*
Re: Error with plgin content
« Reply #3 on: 19.03.2021 11:11:44 »
Quote
to replace the remository component  that will not be compliant with joomla 4.

Hi,
you know that the current jDownloads version will not be compatible with Joomla 4.0?
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!
*
Re: Error with plgin content
« Reply #4 on: 19.03.2021 12:44:06 »
Hi Arno,
Yes, I Do, but according to your website, it should be soon. Remository will  not be it. Moreless, issues are open for years without any news. I am not in a hurry to migrate to Joomla 4, but I want to do it smoothly by changing outdated products step by step. 

Best regards
*
Re: Error with plgin content
« Reply #5 on: 19.03.2021 13:16:41 »
Okay. But the Joomla 4 compatible version will not be ready in the next months. Maybe in the summer.
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!
*
Re: Error with plgin content
« Reply #6 on: 19.03.2021 14:39:10 »
Hi,
I have do a look at your backend.

When I activate the Joomla debug option I get more information about the error (see pic).
For me seems the 'contentmap' plugin to be the reason for the error.

But I get a lot of other errors when the debug option is enabled. I will send you a pic via PM.
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!
*
Re: Error with plgin content
« Reply #7 on: 19.03.2021 15:08:40 »
Effectively, I did a test by deactivating contentmap plugin and it run fine.
What do you advice
Best regards
*
Re: Error with plgin content
« Reply #8 on: 19.03.2021 22:24:33 »
You should contact the contentmap developer.
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!