0 Members and 1 Guest are viewing this topic.

Category links broken (after update?)
« on: 02.09.2020 22:55:14 »

first of all I'd like to thank you for your great work - your tools is quite essential for my projects and it works like like a charm.

With the latest update to 3.9 I'm experiencing a quite strange behaviour. I've put links to jDownload categories on buttons on some pages and it seems that these links are broken. Clicking on such a button (which worked before) now shows an 404 error stating "Parent category not found". But - there is a parent category and using the jDownload dropdown shows the link and everything works well.

The old link (not working anymore) has the format:
(can be reproduced by opening http://weilrod.de/index.php/rathaus-politik/politik/gemeindevertretung and clicking on the button "Protokolle")

If I use the jDownloads dropdown (i.e. here: https://weilrod.de/index.php/rathaus-politik/buergerinformation/formulare) I can select "All Downloads" and then open "Protokolle"and afterwards "Gemeindevertretung" easily. This is  working and linking to:

Of course I could change all links and everything would be fine. But as this worked before and using such buttons quite heavily I'm wondering if there is another way to get the links working again.

Thanks in advance and keep on going with this great tool.

Here my system config:
Datenbanktyp   mysql
Datenbankversion   5.7.30-33-log
Datenbankzeichensatz   utf8_general_ci
Datenbankverbindungszeichensatz   utf8mb4_general_ci
PHP-Version   7.3.18-he10.1
Webserver   Apache
PHP-Interface für den Webserver   apache2handler
Joomla!-Version   Joomla! 3.9.21 Stable [ Amani ] 25-August-2020 15:00 GMT
Joomla!-Plattform-Version   Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
Browsererkennung   Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.2 Safari/605.1.15
Re: Category links broken (after update?)
« Reply #1 on: 05.09.2020 00:23:46 »

We have found a bug in the 3.9.4 version that causes the problem you are seeing. This has been solved in 3.9.5 which is undergoing final testsThere is a pre-release version at http://www.jdownloads.com/forum/index.php?topic=12128.msg45112
Altrenatively you can now revert back to the jD 3.2 serieis by follwing the details in article
If you need help please ask.  In my view the safest route is to revert back to 3.2.

ColinPS thankyou for all the details in your post
Colin M