www.jdownloads.com

0 Members and 1 Guest are viewing this topic.

Hello,

I have updated from 3.2 to 3.9.

Thanks Arno for many things and many hours work!

I have an article with the plugin "Regular Labs - Components Anywhere":
https://www.regularlabs.com/extensions/componentsanywhere

This works fine with 3.2, but with 3.9 the side is empty...

The "Regular Labs Modules Anywhere" works, for example at the bottom of this side:
https://tauber-leipzig.de/gewandhausorchester.html

Can you fix this?

Greetings!
TomNow Solved - see end of these posts - Not a jD problem Colin
« Last Edit: 05.10.2020 18:30:57 by ColinM »
*
Re: Regular Labs - Components Anywhere not working
« Reply #1 on: 23.08.2020 21:18:38 »
Hi
Could you point me to which article where you have Components Anywher pleaseThanksColin
Colin M
Re: Regular Labs - Components Anywhere not working
« Reply #2 on: 23.08.2020 23:16:11 »
For example:
https://tauber-leipzig.de/index.php?option=com_content&view=article&layout=edit&id=88

This can you read with {F12}:

<!--  Components Anywhere Message: Die Komponente kann nicht platziert werden wegen einer ung├╝ltigen URL oder einer Zeit├╝berschreitung der Seite. -->

Greetings!
Tom
*
Re: Regular Labs - Components Anywhere not working
« Reply #3 on: 24.08.2020 10:43:46 »
TomI translated the message as my German is 'tourist' level!
"The component cannot be placed because of an invalid URL or the page timed out."
Components anywhere uses a menu item to define the link and also to set up 'parameters'Could you advise which jDownloads menu item you are using please and also any menu parameter changes so I can attempt to simulate the problem
ThanksColin


Colin M
Re: Regular Labs - Components Anywhere not working
« Reply #4 on: 24.08.2020 11:39:00 »
Hello Colli,

this is the HTML:

<div class="uk-card uk-card-primary uk-card-body">
{component index.php?option=com_jdownloads&view=category&catid=2}
</div>

in the:
https://tauber-leipzig.de/index.php?option=com_content&view=article&layout=edit&id=88

This Link is okay:
https://tauber-leipzig.de/index.php?option=com_jdownloads&view=category&catid=2

And the
{component index.php?option=com_jdownloads&view=category&catid=2}
works fine in 3.2

The same with url="" also not working.
Here an example:
https://www.regularlabs.com/forum/componentsanywhere/47393-components-anywhere-not-working-on-joomla-3-9-13
on #90407

And this with module - for example - works in 3.9:

<div class="uk-card uk-card-primary uk-card-body">
{module Tom_jDownloads Latest-Diensteinteiler}
</div>

Greetings!
Tom
Re: Regular Labs - Components Anywhere not working
« Reply #5 on: 26.08.2020 15:42:07 »
Sorry, the last lines must be called with {}:


module Tom_jDownloads Latest


« Last Edit: 26.08.2020 15:44:16 by TomTau »
Re: Regular Labs - Components Anywhere not working
« Reply #6 on: 05.10.2020 08:51:28 »
Hello,

I have found a workaround...

When I deactivate the SEO is work fine.
With SEO = On is not working.

Can you help for this?
My jDownloads = 3.9.6

Greetings!
Tom
*
Re: Regular Labs - Components Anywhere not working
« Reply #7 on: 05.10.2020 14:30:50 »
Hi
I will try to reproduce in one of my test sites.
I guess it is the structure of the menu link that is causing a 'challenge' as that is the principle difference.
Presume you are using the Free Version of Compnents anywhere.
Also could you try with the latest jD 3.9.6 version of jD (just released) please.
I use several Regular Labs extensions on my regular sites

Colin
Colin M
*
Re: Regular Labs - Components Anywhere not working
« Reply #8 on: 05.10.2020 15:02:53 »
Hi
 Have you by any chance set 'Force Itemid' in Advanced section of Components Anywhere to Yes?
Colin
Colin M
Re: Regular Labs - Components Anywhere not working
« Reply #9 on: 05.10.2020 15:05:45 »
Hi
 Have you by any chance set 'Force Itemid' in Advanced section of Components Anywhere to Yes?
Colin

Yes, but with the same reslut.
*
Re: Regular Labs - Components Anywhere not working
« Reply #10 on: 05.10.2020 15:12:29 »
Hi
In the Documentation of Component Anywhere

"As said above, we recommend you use the non-sef url inside the {component} tag. But getting that url is not that straight-forward for some components."
This is in sectionUsing Menu Item to get the correct URL
Colin
Colin M
Re: Regular Labs - Components Anywhere not working
« Reply #11 on: 05.10.2020 15:15:51 »
I have not the SEO-tag in my code, for example:
 {component url="index.php?option=com_jdownloads&view=category&catid=2"}

Greetings!
Tom
*
Re: Regular Labs - Components Anywhere not working
« Reply #12 on: 05.10.2020 17:29:28 »
Tom
But have just seen that on the 'test site' in a custom module!
Which article has the (component  ....}
Colin M
Re: Regular Labs - Components Anywhere not working
« Reply #13 on: 05.10.2020 17:50:57 »
Sorry, my english...

I have this in my custom modul ("Tom_GWO-CDs - Downloads"):

{component index.php?option=com_jdownloads&amp;view=category&amp;catid=2}

This works with SEO = Off

And this isn't working with SEO = On

This isn't an article, but a custom module.

Greetings!
Tom
*
Re: Regular Labs - Components Anywhere not working
« Reply #14 on: 05.10.2020 18:26:06 »
Tom
Have solved the problem  It wouls seem the Components Anywhere  has 'changed'
It now needs the Itemid of the menu item
{component index.php?option=com_jdownloads&view=category&catid=XXX&Itemid=YYY}
where XXX is the catid and YYY is the relevant menu id

Colin
Colin M