0 Members and 1 Guest are viewing this topic.

Having problems with uploading large files
« on: 03.01.2022 15:39:48 »
Hello All,

Can I have support with our Joomla 3.9 & JDownloads We have problems to upload large files.
We need upload some over 2GB files occasionally.

Server settings are:
Allowed file uploads:    Yes
Maximum allowed file size (max_filesize):    3000M
Maximum allowed POST size: (post_max_size):    3000M
Memory limit (memory_limit):    1G
Maximum input time for uploads (max_input_time) in seconds:    300
Maximum execution time of scripts (max_execution_time) in seconds:    300

When I try upload about 250Mb file, I get following error message after about one minute:
Invalid file size found. File upload aborted.
Anyone knows what can cause this error?

On upload screen, there is also this text:
Allowed maximum size (site): 204800 KB
I can't find this setting anywhere. Where to look for it?

Is there Log files with more accurate information somewhere? I can't find it.
Server is running on Apache 2.4 with PHP 7.4.

Re: Having problems with uploading large files
« Reply #1 on: 04.01.2022 10:45:40 »
If you go to jD Options - Uploads tab you will see the option 'Maximum File Size' - it also shows the php maxfile size.  This applies to the max size when uploading fomthe backend.  See

For the Front End you can specify the max size in the relevant User Group Settings - Group Creation/Editting tab- option Maximum File Size in KB (kilobytes).  Note that which user group applies depends on the Ranking level of the user group.

Generally I define a User Group called something like uploaderUG and set its ranking to say 131.  Then allocate users you wish to allow to upload to that User Group.  Also useful to create a view Access level called say uploader-view to attach to a menu item such as Create Download.

There is a whole section on User Group settings see
but you might start at  with the overview

Colin M
Re: Having problems with uploading large files
« Reply #2 on: 04.01.2022 12:58:40 »
Thank You for quick and good answer :D
Problem was in group settings like you think. We have pretty simple service, only superadmins can upload, so no more groups needed.