0 Members and 1 Guest are viewing this topic.

Error 500 after upgrade
« on: 07.12.2020 10:14:27 »

I've upgraded Jdownloads from 3.2 to
I created the 2 directories /downloads and /downloads/tempzipfiles (chmod 777) but I on frontend I have this error:

500 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 17

If I check download area it tells that the main folder doesn't exist

Please what can I do to fix this?

thank you
Re: Error 500 after upgrade
« Reply #1 on: 07.12.2020 16:03:16 »

From what you describe it sounds as if folder jdownloads in the root failed to get created or perhaps has insufficient priveleges (chmod)
First please look at Joomla! System - Global Configuration - Server tab option 'Path to Temp Folder'  This will  point to your Joomla 'base' directory with /tmp added at the end

  Now in jD Options - Path Settings tab - Upload directory path.  This should be "Joomla 'base'  directory with /jdownloads added at the endCheck the chmod of that directory.
Also could you please advise which database  and its version your site is using.  You need either MySQL 5.7+ or Maria DB 10.2+ or PostGreSQL 9.5+Colin
Colin M
Re: Error 500 after upgrade
« Reply #2 on: 07.12.2020 17:41:12 »

I solved simply restoring a backup made on a copy of the site in a subdirectory where the upgrade had been successfull.

(Anyway the settings where the same on both site...  :o I really do not understand)
Re: Error 500 after upgrade
« Reply #3 on: 08.12.2020 21:12:00 »
I am in the same boat.  It seems that I missed the database version requirement (I have MySQL 5.5), yet the upgrade to jD 3.9 was able to go through.  I'm trying to see if I can get my host to upgrade MySQL.
Re: Error 500 after upgrade
« Reply #4 on: 08.12.2020 22:21:51 »
Actually, my host says I am running MariaDB version 10.4.12.  I'll create a separate thread on my issue.