jDownloadsownloads.com


Author Topic: Permission issue  (Read 264 times)

0 Members and 1 Guest are viewing this topic.

Offline sripoll

  • Newbie
  • *
  • Posts: 3
Permission issue
« on: 08.06.2019 15:26:55 »
Hi,

Having transferred my site to a different hoster, I get the following error "Upload root directory /public_html/jdownloads does not exist".
Meanwhile the directory exists and has the correct permissions (0755).

What may I miss here ?

Thanks and best regards.

See attached screenshots : error message, site directory hierarchy as seen from FileZilla.

Offline Arno

  • Administrator
  • ***
  • Posts: 12.476
    • jDownloads.com
Re: Permission issue
« Reply #1 on: 08.06.2019 16:59:33 »
Hi,
go to the configuration tab Downloads and type in the correct new absolute path in the field Upload directory path
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline sripoll

  • Newbie
  • *
  • Posts: 3
Re: Permission issue
« Reply #2 on: 10.06.2019 16:01:54 »
Thanks for your reply.
This is what I did.
The download absolute path seems correct (displayed in green). However the immediate subdirectories still are displayed in red, although the root path has been correctly modified as a consequence of setting the upload directory path.

See attached screenshot n°1.

On the front-end side, I can see my downloads but none can be accessed. An error message is displayed when attempting to download a file, stating the file is non-existent.

See attached screenshots  n°2 and n°3.

Any clue on what is going on ?
Best regards.
-- Stéphane --
« Last Edit: 10.06.2019 16:05:43 by sripoll »

Offline ColinM

  • Moderator
  • *
  • Posts: 3.975
Re: Permission issue
« Reply #3 on: 11.06.2019 14:25:22 »
Hi
OK you need to append /jdownloads to give the absolute address to the jdownloads directory
Colin

Offline Juthamas

  • Newbie
  • *
  • Posts: 1
    • แทงบอล
Re: Permission issue
« Reply #4 on: 24.06.2019 12:40:52 »
 This article is very good. I like to read a lot.