jDownloadsownloads.com

Advertisement
Advertisement:

Author Topic: Tags doesn't work [solved]  (Read 354 times)

0 Members and 1 Guest are viewing this topic.

Offline mzanotto

  • Newbie
  • *
  • Posts: 4
Tags doesn't work [solved]
« on: 19.06.2017 19:09:26 »
Hi,
I tagged some downloads from the backend, those tags are visible in frontend related to each download but if I click on it joomla opens the tag component without any results.

If I tag a category instead of a download, they work

What am I wrong?

Thanks,
Max
« Last Edit: 04.07.2017 22:56:34 by ColinM »

Offline ColinM

  • Moderator
  • *
  • Posts: 3.029
Re: Tags doesn't work
« Reply #1 on: 20.06.2017 10:50:12 »
Hi
First could you advise which version of Joomla! and which version of jDownloads you are using please. 
Have you read
http://www.jdownloads.net/documentations/item/tags-support-in-jdownloads

If it is that tags are not showing please check your menu settings as described in the document. 

Should there still be a problem then if you send me a Private Message (click on white squarish box near my name) with site details and I will look further

Colin

Offline mzanotto

  • Newbie
  • *
  • Posts: 4
Re: Tags doesn't work
« Reply #2 on: 20.06.2017 12:48:53 »
Hi Colin and thanks,
I'm using Joomla 3.7.2 and Jdownloads 3.2.51

I read the linked documents (many times) but without being able to understand the problem.
I can see the tags associated but when I click on them, I have no result in the search page

Offline mzanotto

  • Newbie
  • *
  • Posts: 4
Re: Tags doesn't work
« Reply #3 on: 20.06.2017 15:21:05 »
I think something goes wrong upgrading from 3.2.42, I removed the component and reinstall and now everythings work

Thanks,
Max

Offline ColinM

  • Moderator
  • *
  • Posts: 3.029
Re: Tags doesn't work
« Reply #4 on: 20.06.2017 15:36:16 »
Max,
Glad the problem has disappeared.
As well as re-installing jD did you also update Joomla! ?  I ask because we are awaiting a Joomla! patch to handle some things when a component is using its own categories.  It was due to be in 3.7.x but status is 'unclear'.
Colin
PS the problem was introduced by Joomla! team in Joomla! 3.4.6
« Last Edit: 20.06.2017 15:39:19 by ColinM »

Offline mzanotto

  • Newbie
  • *
  • Posts: 4
Re: Tags doesn't work
« Reply #5 on: 21.06.2017 11:46:06 »
yes, i updated joomla and then jD.
The strange thing is that I have a dev site (but without many content) where I did the same steps and on it everything goes well.
I really don't explain to myself why on the prod site there was this problem.

BTW now everything is ok :)

Offline newmy

  • Newbie
  • *
  • Posts: 6
Re: Tags doesn't work [solved]
« Reply #6 on: 13.09.2017 18:27:34 »
I have the same problem (sorry for the double post ...)

is reinstalling the only solution?

newmy

Jdownloads 3.2.55
Joomla 3.7.5
PHP 7.1.6

Offline ColinM

  • Moderator
  • *
  • Posts: 3.029
Re: Tags doesn't work [solved]
« Reply #7 on: 14.09.2017 10:13:21 »
Hi
Sometimes if you have migrated from an earlier series of jD (eg from jD 1.9.x) the host server sometimes runs out of processing time time. so re-installing the Component tidies up.  Of course you leave the files and database items in place as that is an option in the Uninstall.

However if it was not a migration then do not uninstall and reinstall.  There has been a 'grumbling' debate in the Joomla! team where in one release they introduced a bug that failed to recognise that many Components have Categories.  This caused the failure of Tags.  With the lates version of Joomla! it looks OK but you may need to remove some tags set up previously and after clearing all caches reintroduce them.  Tags on Downloads were OK, it was the Categories that suffered the bug.

Colin

Offline newmy

  • Newbie
  • *
  • Posts: 6
Re: Tags doesn't work [solved]
« Reply #8 on: 14.09.2017 11:39:17 »
Hi Colin,
the Categories are ok - they are in the list when clicking on the Tags displayed in a list of files in a categorie. (beneath articles).
On our site its the Downloads that are missing.
We did not have using TAGS before.

Yes we migrated from 1.9 but thats months ago when migrating to 3.x.

Our Issue is exact described in http://www.jdownloads.com/index.php/support-forum.html?topic=9270

What do you suggest?

newmy

tags1.png  shows the tags in a categorie of Downloads
tags2.png shows clicking on tag "xft-documentcomposer"
tags3.png shows clicking on tag "xft add-on 4.60" only showing a Categorie


 

Advertisement