jDownloadsownloads.com


Author Topic: Cannot upgrade from jDownloads 1.9.0 Stable 926  (Read 1645 times)

0 Members and 1 Guest are viewing this topic.

Offline 3cellhosting

  • Newbie
  • *
  • Posts: 3
Cannot upgrade from jDownloads 1.9.0 Stable 926
« on: 18.12.2015 14:41:04 »
Hello support,

I am having a major problem trying to upgrade a site that has 1299 downloads.

The current version is jDownloads 1.9.0 Stable 926 on Joomla 2.5. I have printed the instructions out and fall over at first hurdle.

When I use the com_jdownloads_1.9.1.6_stable_joomla_2.5 to do upgrade I get the following error...

Code: [Select]
JInstaller: :Install: Error SQL DB function failed with error number 1146
Table 'pendingw_churchcare.i4ai7_jdownloads_categories' doesn't exist SQL=ALTER TABLE `i4ai7_jdownloads_categories` ENGINE=innodb;
SQL =
ALTER TABLE `#__jdownloads_categories` ENGINE=innodb;
Component Update: SQL error file DB function failed with error number 1146
Table 'pendingw_churchcare.i4ai7_jdownloads_categories' doesn't exist SQL=ALTER TABLE `i4ai7_jdownloads_categories` ENGINE=innodb;
SQL =
ALTER TABLE `#__jdownloads_categories` ENGINE=innodb;

Searching the forums I found just one other post a year ago but with no solution. I have unpacked the extension and done a search on files and cannot find that ALTER TABLE instruction for that table so I have no idea where this is coming from.

I have looked through the existing tables in case it is named anywhere. I see that the table exists in later versions so I suspect that there has been some previous attempt to upgrade the site. If this is the case how can I get this upgrade moving again?

Thanks

David

********************
UPDATED INFORMATION
********************

It must have been a failed upgrade as I found additional files while making a comparison of the extracted 1.9.1.6 version against 1.9.0 version on site. In public_html/administrator/components/com_jdownloads/sql/ there are 2 files one of which is install.mysql.utf8.sql and this includes the instruction for ALTER TABLE `#__jdownloads_categories` ENGINE=innodb;

It also has lots of files in the update directory too.

I am going to upload files manually and delete the differences and the retry. I will post back if results work.

Thank you.
« Last Edit: 18.12.2015 15:39:40 by 3cellhosting »

Offline ColinM

  • Moderator
  • *
  • Posts: 3.642
Re: Cannot upgrade from jDownloads 1.9.0 Stable 926
« Reply #1 on: 18.12.2015 16:57:01 »
Hi
Yes please keep us posted.
It may be better if you actually think of migrating to Joomla! 3.x

I suspect that the very old 1.9.0 Stable 926 does not have quite as many capabilities as the latest jD 3.2 series.  So it might be a solution to do this the very simple way of creating the categories, turn off auto-monitoring off and then loading up a few files at a time, then do a manual start of the monitoring from the control panel. Boring but may be less stressful! 
 Note a problem can be if you have any Content Downloads in articles as the ids may have changed - this is better in the 3.2 series.

Colin

Offline 3cellhosting

  • Newbie
  • *
  • Posts: 3
Re: Cannot upgrade from jDownloads 1.9.0 Stable 926
« Reply #2 on: 18.12.2015 17:58:33 »
Hi Colin,

We are already in process of migrating to Joomla 3 and jdownloads is the last (hopefully) stumbling block.

I will report back later tonight.

Regards

David

Offline 3cellhosting

  • Newbie
  • *
  • Posts: 3
Re: Cannot upgrade from jDownloads 1.9.0 Stable 926
« Reply #3 on: 19.12.2015 14:14:07 »
OK - after some unexpected delays I finally got around to deleting all files NOT included in the extension when unzipped.

This immediately solved the upgrade issue from 1.9.0 stable 926 to 1.9.16.

We will now check documentation and see if we can update further. Will report back if all works.

Regards

David

Offline ColinM

  • Moderator
  • *
  • Posts: 3.642
Re: Cannot upgrade from jDownloads 1.9.0 Stable 926
« Reply #4 on: 22.12.2015 01:29:31 »
David
One of the many improvvements in jD3.2 series is that all the modules and plugins specific to jD are in the zip. Of course those that integrate with other extensions are separate.
Hope the migration goes well.
Colin