jDownloadsownloads.com



Author Topic: Error 404 in lightbox.js of content-plugin  (Read 2865 times)

0 Members and 1 Guest are viewing this topic.

Offline clausw

  • Newbie
  • *
  • Posts: 15
Error 404 in lightbox.js of content-plugin
« on: 08.04.2015 12:27:11 »
Environment
-------------------------
jDownloads 1.9.2.11 Beta
Joomla! 3.4.1


At showing an single article, I got two 404-Error for loading GIFs: loading.gif and close.gif

I think the location of the error is in file: plugins/content/jdownloads/jdownloads/lightbox/lightbox.js

In line 40 and 41 the follwing JS code is present:
Code: [Select]
var loadingImage = 'components/com_jdownloads/assets/lightbox/loading.gif';
var closeButton = 'components/com_jdownloads/assets/lightbox/close.gif';

Wheni replace the JS-Code with the following, the 404-Errors are not longer present in the logs:
Code: [Select]
var loadingImage = live_site+'components/com_jdownloads/assets/lightbox/loading.gif';
var closeButton = live_site+'components/com_jdownloads/assets/lightbox/close.gif';

In the file lightbox.js of the component is addidional an if-statement, but I not really understand what it should do with "live_site",
because the code from there doesn't work in the JS-File of the plugin: components/com_jdownloads/assets/lightbox/lightbox.js
Code: [Select]
// If you would like to use a custom loading image or close button reference them in the next two lines.
if ( typeof live_site != "undefined"){
   var loadingImage = live_site+'components/com_jdownloads/assets/lightbox/loading.gif';
   var closeButton = live_site+'components/com_jdownloads/assets/lightbox/close.gif';
} else {
   var loadingImage = 'components/com_jdownloads/assets/lightbox/loading.gif';         
   var closeButton = 'components/com_jdownloads/assets/lightbox/close.gif';
}

I know I should migrate to the newer version of jDownloads, but at my last attempt, I got some problems  ???
Maybe I start a new attemp soon!

best regards
Claus

Offline ColinM

  • jD Tester
  • *
  • Posts: 3.477
Re: Error 404 in lightbox.js of content-plugin
« Reply #1 on: 08.04.2015 14:00:27 »
Hi Claus,
Afraid I do not know about the 1.9.2 series! I do not even have a test site with jD1.9.2 now.  The only time I load one is to check out the coversion to the jd3.2 series.   Officially support has ended for all the 1.9.x series but we do try to help where possible.

In your situation the best scheme is to migrate to jD3.2, first on a test site.  Many, many people have done this successfully following the article "How to upgrade jDownloads component from 1.9.2.11 to latest 3.x version?" which is at http://www.jdownloads.net/documentations/item/how-to-upgrade-jdownloads-component-from-1-9-x-to-latest-3-x-version

It is a multi step problem and needs to be done carefully.  I actually advise people to print out the article and tick each step as they do it.  Sometimes there are permission problems after doing the migration so see http://www.jdownloads.net/documentations/item/permissions-problems-after-migration-to-new-series

Another situation may occur if you have a large number of jD categories and downloads.  This is because your server may run out of resources, particularly time.  In this situation it is best to do the upgrade on your PC using WAMP or similar as that is easy to add resources.  It usually takes longer, well it does on my poor old PC as it is not as 'powerful' as most decent web servers.  But I can leave it running whilst I do other things (sitting watching it is like watching paint dry - totally boring!).  If one gets it converted with WAMP or similar then do a jD Backup, replace all the files on the server in directories jdownloads and images/jdownloads with those from your PC using  FTP ( I use File Zilla).  The run the jD restore.  Note you need to be careful about the database name and the prefix.  As the jD backup file is a straight text file then it is easy to edit these. I use Notepad++.

One of my planned tasks today is to complete an article about using WAMP as part of the migation - but I had that task last week as well!!  Dedpends how many jD forum things need help.

Colin

Offline clausw

  • Newbie
  • *
  • Posts: 15
Re: Error 404 in lightbox.js of content-plugin
« Reply #2 on: 08.04.2015 16:40:50 »
Hi Colin,

i know the 1.9-version is out of support, but maybe my posting help somebody to fix the problem, while the installion is not migrated to the new version.
 ;)

best regards & thank you for your work!
Claus

Offline gorrion007

  • Newbie
  • *
  • Posts: 1
    • http://maschistesbuenos.com/category/chistes-cortos/
Re: Error 404 in lightbox.js of content-plugin
« Reply #3 on: 28.08.2015 04:53:25 »
Thanks ColinM, I Follow the instructions and my problem was solved. Thank you.