jDownloadsownloads.com



Author Topic: blank page after restore attempt in J3.2  (Read 12898 times)

0 Members and 1 Guest are viewing this topic.

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
blank page after restore attempt in J3.2
« on: 10.12.2013 06:11:53 »
Hope you're enjoying your holidays over there in Germany. Thanks for looking at this when you can.

- Jooomla ver 3.2.0
- jDownloads ver  1.9.2.8_beta_for_joomla_3.1
- System Information:
PHP Built On    Linux uswest3.myserverhosts.com 2.6.18-448.4.1.el5.lve0.8.69.1 #1 SMP Tue Jul 2 18:36:25 EEST 2013 x86_64
Database Version    5.1.70-cll
Database Collation    utf8_general_ci
PHP Version    5.3.13
Web Server    Apache
WebServer to PHP Interface    cgi-fcgi
Joomla! Version    Joomla! 3.2.0 Stable [ Ember ] 6-November-2013 14:00 GMT
Joomla! Platform Version    Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
User Agent    Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

- Linux site on uswest3.myserverhosts.com
- I have deactivated all Cache and Compress options in the Joomla configuration and template settings

What is the problem in detail:
- What you were trying to do, what the errors were.
I as trying to transfer from a J1.5 jdownloads 1.82 installation to Jdownloads 1.9.2.8 beta installation on J3.2.0

- What you have tried to solve the issue (changing settings).
Don't know what t do.

- What searches you have done.
Checked the form, google etc. but you suggested I search/post on the forum if I get a blank page after restoration attempt

- Add screenshots to the post: A picture is often better than a thousand words! You can easy it submit as attachment.
Nothing to screen grab... the source code of the resultant page has this (hidden) code on it:

<script type="text/javascript">
    /* for modal output */
    function openWindow (url) {
        fenster = window.open(url, "_blank", "width=550, height=480, STATUS=YES, DIRECTORIES=NO, MENUBAR=NO, SCROLLBARS=YES, RESIZABLE=NO");
        fenster.focus();
    }
     
    function getSelectedText( frmName, srcListName ) {
        var form = eval( 'document.' + frmName );
        var srcList = eval( 'form.' + srcListName );

        i = srcList.selectedIndex;
        if (i != null && i > -1) {
            return srcList.options.text;
        } else {
            return null;
        }
    }
   
</script>

- When it is needed , send a site link to the problem via PM
- If using specially Extensions (SEF addons as sample)
no SEF extensions, only Jumi and JCE installed. I'll remove them and try again, but I don't think this will fix it.

Appreciate you help. This is a big installation and I really want to avoid having to re-create it. Happy to pay for your trouble. This is a licensed installation for 1.5, but have just sent you a $20 USD donation for the new J3.1 license - let me know if it's more than that now.

cheers
Garth Penglase, Broadband Media

Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #1 on: 10.12.2013 12:27:27 »
Hi,
Quote
I as trying to transfer from a J1.5 jdownloads 1.82 installation to Jdownloads 1.9.2.8 beta installation on J3.2.0
Have you read before the 'how-to' for this in documentation?
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #2 on: 11.12.2013 02:38:19 »
As in http://www.jdownloads.net/documentations/item/how-to-move-jdownloads-from-joomla-1-5-to-joomla-2-5  ?
Of course. Have been following your instructions to the letter.
Note your entry...
"Check the restore result message - when it was not possible to restore it successful, you can not goes to the next step! The succesful restoration from the backup file is very important. Otherwise works jDownloads not correctly. So you must find first a solution for this. To check it more, you can activate the debug option in the Joomla configuration. It is also useful to set higher the error reporting level (TAB: Server). Sometimes (very rare) is only viewed a blank page, please use then the support forum."

Given that I have also been totally unsuccessful in Joomla core using either jUpgrade, jUpgradePro or redMigrator, I decided to transfer that manually and moved onto trying to migrate the jDownloads data. No such luck.

Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #3 on: 11.12.2013 13:35:19 »
Please send me login data via PM.
I will then contact you later today when i am back in office.
« Last Edit: 11.12.2013 13:36:50 by Arno »
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #4 on: 12.12.2013 11:28:41 »
Thanks for the data.

Are you sure, that you have all this done correctly in your first try? See marked area in pic.
Very important is here also the DB prefix part...

I can try it for you again, but need then database access for phpmyadmin (via PM).
But i can not move the download files, this must you do self.
« Last Edit: 12.12.2013 11:30:46 by Arno »
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #5 on: 12.12.2013 12:21:55 »
Yes Arno,
followed it to the letter - it is very straightforward. Old table prefix was jos_ (as usual for J15) and the new is jm32_
I'll give you CPanel/FTP access via PM.

I will also upload to you the config files for the J32 install so you can see the details in the backup file are correct. And of course the backup file.

This is really quite an obvious and simple thing... turn off auto monitoring in ver 1.9.2.8, clear out the old junk and cache, logs etc in the old from 1.8.2 ver and backup to text file, change table prefix, move image/jdownloads across, delete and copy old jdownloads folder across, restore backup.


Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #6 on: 12.12.2013 12:25:12 »
Yes Arno,
followed it to the letter - it is very straightforward. Old table prefix was jos_ (as usual for J15) and the new is jm32_
I'll give you CPanel/FTP access via PM.

I will also upload to you the config files for the J32 install so you can see the details in the backup file are correct. And of course the backup file.

This is really quite an obvious and simple thing... turn off auto monitoring in ver 1.9.2.8, clear out the old junk and cache, logs etc in the old from 1.8.2 ver and backup to text file, change table prefix, move image/jdownloads across, delete and copy old jdownloads folder across, restore backup.

It's a new & clean J32 install, however I did install JCE and Jumi first. I'll remove those now, but I don't see why they'd cause any problems, but you never know.

Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #7 on: 12.12.2013 12:27:01 »
Quote
This is really quite an obvious and simple thing... turn off auto monitoring in ver 1.9.2.8, clear out the old junk and cache, logs etc in the old from 1.8.2 ver and backup to text file, change table prefix, move image/jdownloads across, delete and copy old jdownloads folder across, restore backup.
Sure it is very easy normally.

What exactly is the result from the last step: Restore backup file. ?
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #8 on: 12.12.2013 12:33:09 »
nothing but blank page with this source code:

<script type="text/javascript">
    /* for modal output */
    function openWindow (url) {
        fenster = window.open(url, "_blank", "width=550, height=480, STATUS=YES, DIRECTORIES=NO, MENUBAR=NO, SCROLLBARS=YES, RESIZABLE=NO");
        fenster.focus();
    }
     
    function getSelectedText( frmName, srcListName ) {
        var form = eval( 'document.' + frmName );
        var srcList = eval( 'form.' + srcListName );

        i = srcList.selectedIndex;
        if (i != null && i > -1) {
            return srcList.options.text;
        } else {
            return null;
        }
    }
   
</script>

Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #9 on: 12.12.2013 12:54:22 »
Okay. i have found it.  ;)

It was a problem with a few used single quotes. So i must temporary remove it in backup file.
Please use the backup file below. Make sure that you have before all other do from the list (files move!).

Note: normally are single quotes not a problem, so i am not sure why it is in your case different.  ::)
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #10 on: 12.12.2013 13:10:47 »
sorry to say, but it gave me exactly the same error: a blank page and this source code.
I went through and checked the jdowloads folder again just to make sure that I'd copied all of the files across from the old install over. all there.

<script type="text/javascript">
    /* for modal output */
    function openWindow (url) {
        fenster = window.open(url, "_blank", "width=550, height=480, STATUS=YES, DIRECTORIES=NO, MENUBAR=NO, SCROLLBARS=YES, RESIZABLE=NO");
        fenster.focus();
    }
     
    function getSelectedText( frmName, srcListName ) {
        var form = eval( 'document.' + frmName );
        var srcList = eval( 'form.' + srcListName );

        i = srcList.selectedIndex;
        if (i != null && i > -1) {
            return srcList.options.text;
        } else {
            return null;
        }
    }
   
</script>

Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #11 on: 12.12.2013 13:21:11 »
Very strange. In my installation it works proper.  ::)
I will try to import it directly via phpmyadmin.... give me a few minutes.
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #12 on: 12.12.2013 13:28:56 »
first i thought i was having problems when trying to do a joomla upgrade (i tried jupgradePro and redmigrator) but i couldn't get it to work on a Softalacious install of j32 so I reinstalled with a joomla.org version of J316 and that didn't work either, so I gave up and upgraded J316 to J32 and installed jdownloads latest and followed the instructions. so unless instaling and then uninstalling JCE and Jumi has affected something i can only think that it must be a slight server difference. there's plenty of disk space and no load on the server. I haven't set any htacces file in the new installatin yet or done anything else to it.

Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #13 on: 12.12.2013 22:27:49 »
I have now restored the db data using phpmyadmin.
- all seems okay but only a single download is not full valid? See result from monitoring pic 2
- you must now also check the user groups in jDownloads - pic 1
- delete the old Joomla 1.5 data only when you are sure to hundred percent that all works proper in Joomla 3.2.

It was in your case a little tricky to get the data valid in joomla 3.2.
So a donation is very welcome - see donation module on main site.  ;D
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #14 on: 13.12.2013 05:11:08 »
Thanks Arno,
I donated the day before yesterday (second time for this site), and happy to add more for the work you've done to help and promptness with which you did it. Will also put a 5star review on JED.

However, I noticed that the version in the J32 installation is now jDownloads 1.8.3 Stable 860, whereas I installed the latest version 1.9.28 beta recommended on the jdownloads.com forum site. SO was this the fix. If I had known there was a earlier stable version which worked with J3.2.0 I would have saved you the trouble of this and installed that. If that's the case, can I suggest that you change the reference on the jdownloads site to a more stable version?


Offline Arno

  • Administrator
  • ***
  • Posts: 12.234
    • jDownloads.com
Re: blank page after restore attempt in J3.2
« Reply #15 on: 13.12.2013 08:54:11 »
Thanks for the donation.

Quote
... I noticed that the version in the J32 installation is now jDownloads 1.8.3 Stable 860...
I think you mean on your old J1.5 site. The jD 1.8.3 is not for Joomla > 1.5, so this has nothing to do with your problem.

By the way, i think this is not really a bug then other users has not this problem with data moving to Joomla 3.x.
« Last Edit: 13.12.2013 08:56:02 by Arno »
Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions directory!

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #16 on: 13.12.2013 11:59:07 »
Hi Arno,
I've attached a gif of the screenshot from J32 showing what I meant.

I notice that the backup program  saves the JDownloads version as well - it may be something you want to change.

I checked my backup file (modified) which shows version 1.8.2 856 and then your version (fixed) which shows 1.8.3 (860) so you must have loaded it into your own J15 version 1.8.3 (860) version and then exported it from there.

Anyway, no problems. Thanks for that.

As to where the problem lies, you'd know better than I - all I know is that with a clean J3.1.6 or J3.2.0 install I repeatedly couldn't get either jUpdate to restore the standard Joomla articles nor jDowloads to restore the backup.

I appreciate your help as it has saved me much time, and will get that review and additional donation through. I just wish you knew what the problem might be and that it would solve my jBackupPro issue as well :-)

Offline bbmedia

  • Newbie
  • *
  • Posts: 10
Re: blank page after restore attempt in J3.2
« Reply #17 on: 14.12.2013 03:53:15 »
Now this is interesting.

I just installed another installation of J3.1.6 and re-tried the redMigrator to see if I could get the rest of the data etc across, and it worked. Then i thought I may as well copy the images and files for jdownloads install 1.9.2.8 and try backing up the data you manually added to the jm3.2 installation.

And guess what? It suffered exactly the same issue: blank screen with the same javascript source code behind the page, and no restoration.

So I can only assume that we're looking at a backup/retore issue here. This new event takes the issue of anything to do with the old J15 install right out of the picture. I mean, that's backing up from one working J32 install and then restoring it on the same version of jdownloads on a j316 install. It should work. So either it's a prob with memory or it's a problem with the backup/restore process, because the J316 install was totally clean of everything except redMigrator and the newly transferred data.