jDownloadsownloads.com


Author Topic: Problem with upload downloads?  (Read 64 times)

0 Members and 1 Guest are viewing this topic.

Offline sdslav

  • Newbie
  • *
  • Posts: 1
Problem with upload downloads?
« on: 19.02.2019 12:56:38 »
Hi there,

I have the following problem:
I have installed jDownloads on Joomla! 3.9.2 and configured Categories and UserGroups according the instruction. Initialy I have little trouble to adjust User group settings but finaly succed with little exception.

I want to allow registterd users to be abble to create downloads - usually PDF files. I created special group and give it the needed permision to upload and fill the data fields in upload form. Unfortunately when a registered user click on "Save" button, an Error: "Save failed with the following error: Invalid Parent ID" shows.

After that If I check the Downloads in the corresponding category I see that the file is uplouded succesfuly and I can open/download it without anny problem... but this error message confuses my coleagues ?!

I try different options in UserGroup, but still with no succes. I supose that the error may occur due to unpropriate settings of the Joomla, but I am not sure?!

So, could you give me an advise what can be the reason this error appears?

Thank you in advance!

Offline ColinM

  • Moderator
  • *
  • Posts: 3.795
Re: Problem with upload downloads?
« Reply #1 on: Yesterday at 16:12:30 »
HiI will try to help
The error you are reporting is actually a Joomla! error report, not a JD error.  So perhaps there is a permission "confusion" or maybe the Assets table is 'confused'.
It has the name "JLIB_APPLICATION_ERROR_SAVE_FAILED". Apart from being in the Languages it occurs in 8 places in Joomla!
In order to assist I would need Super Admin access to your site.  To send that securely please click on the whitish square with a tail just below my name.  I will then be able to check your permissions setup and also any assets issues.  What is the name of the User Group who are pemitted to upload?  I usually use UploaderUG but the name is unimportant.
Another thought did you try to upload a preview file at the same time?  Or did you also set to upload from another website?

Incidentally did you use a Deny permission anywhere?
Colin