Support-Forum
21.04.2014 12:20:41 *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: 2014-04-01: jDownloads 2.5.0 Beta for Joomla 2.5 published! A Joomla 3.x compatible version comes in the next days!
 
   Home   Help Search Login Register  

Pages: [1]   Go Down
  Print  
Author Topic: Fatal error: Allowed memory size of 67108864 bytes exhausted  (Read 4931 times)
0 Members and 1 Guest are viewing this topic.
edepina
Newbie
*
Offline Offline

Posts: 5


« on: 30.03.2010 17:39:14 »

Hi there,

I get this error when i choose multiple mp3 files for download:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 28842532 bytes) in /home/<output omitted>/components/com_jdownloads/jdownloads.class.php  on line 333

My MP3 files are all approx 15meg in size. I have about 10 in each page. This error occurred when i selected only 2 files for download!!
Correct me if i'm wrong, but its trying to allocate about 28M and the allowed limit i think is 64M, so should it not work???
Logged
Arno
Administrator
***
Offline Offline

Posts: 9.169



WWW
« Reply #1 on: 30.03.2010 19:20:56 »

Hello,
when you use the forum search function ("Fatal error: Allowed memory size"), you see many results for this problem.
Please read here:
http://www.jdownloads.com/forum/index.php?topic=1053.0

Fact is, that the server need more memory as only the file sizes from the marked downloads. The best way is to contact your hoster for the php.ini settings.

By the way, the mass download function is not useful for big files. But you can reduce the amount of files per page. Then you need a less memory size for the temporary zip file. 
Logged

Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions archive!
edepina
Newbie
*
Offline Offline

Posts: 5


« Reply #2 on: 31.03.2010 06:49:32 »

I contacted my host provider, Hostgator, and this is what i got:

PHP settings that cannot be changed

PHP has been configured to use the following settings on our shared and reseller servers:
safe mode = off
memory_limit = 64M MAXIMUM
max_execution_time = 30 MAXIMUM
post_max_size = 64M MAXIMUM
upload_max_filesize = 64M MAXIMUM
enable_dl = Off

The above settings either CANNOT be changed or cannot be exceeded on a shared and reseller account. These limits are set to prevent extremely high resource usage in shared environments. We have found that a majority of the PHP scripts will work within these limits, and the scripts that require more resources are best suited for a VPS or dedicated server. Dedicated servers and VPS can change and raise these settings to any value desired.

We also set the following:
register_globals = On
magic_quotes_gpc = Off

These two settings, and any other PHP settings not aforementioned, can be changed using a custom php.ini file located in the same folder as the script that requires the settings.

NOTE HostGator cannot know why you want or need to change these settings. You are changing these at the advice of your webdesigner or the developer of your script. HostGator can only show you where to make the changes.


So now i seem to have no choice but to disable the option for multiple downloads, so that users can only download 1 file at a time. How do i do that?
Logged
Arno
Administrator
***
Offline Offline

Posts: 9.169



WWW
« Reply #3 on: 31.03.2010 11:18:53 »

Quote
So now i seem to have no choice but to disable the option for multiple downloads, so that users can only download 1 file at a time. How do i do that?
You can change your hoster. 64 MB is a little less. My Hoster has set this to 300 MB. Wink

When you will set off the mass download function, you must activate a (Downloads) layout without checkboxes.
Logged

Best Regards / Gruß
Arno
Please make a Donation for jDownloads and/or write a review on the Joomla! Extensions archive!
Pages: [1]   Go Up
  Print  
 
Jump to:  

-->
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.142 seconds with 19 queries.